II. LAB
Software Required: NI LabVIEW 2012, NI LabVIEW 4.3 Modulation Toolkit.
Functions and VI (Virtual Instrument) from the LabVIEW software to be used in this lab: Case
Structure (Function), Unbundle By Name (Function), MT Generate Filter Coefficients (VI),
Upsample (VI), Convolution (VI), and Bundle By Name (Function).
PART-1: PULSE SHAPING
INPUTS: Input (1-D array of double complex [~15 digit precision]).
OUTPUTS: Output (1-D array of double complex [~ 15 digits precision]) and filter coefficients (1D array of double [64-bit real (~ 15 digits precision)]).
A virtual instrument template (“student_pulse_shaping.vit”) is provided to you with these
inputs and outputs. The template should be populated according to instructions. Then, newly
created VIs are plugged in the simulator and transmitter USRP control files.
PROCEDURE
In this part, we develop a LabVIEW virtual instrument as a pulse shaping filter that can use the
digital modulated symbols as input and shapes them into analog pulse trains which makes them
suitable for transmission over wireless channel using USRP N210 as the transmitting hardware.
We now detail the construction of the VI at hand in Lab View:
a) Setup
* Open the LabVIEW program (Start > All Programs > National Instruments > LabVIEW 2012 >
LabVIEW 2012).
* Open “student_pulse_shaping.vit” file (Open Existing (OR Ctrl+O) > Select
“student_pulse_shaping.vit” > OK). A basic graphic user interface (GUI) opens. (NOTE: If a
warning window pops up, click on “Ignore” option.)
* Open Block Diagram (Window > Show Block Diagram (OR Ctrl+E)).
* Enable Functions Palette (View > Functions Palette or right click on anywhere of the block
diagram window).
* Place a Case Structure box (Functions Palette > Programming > Structures > select and drag
Case Structure) to enclose two Unbundle by Name boxes after “modulation parameters in”.

b) Pulse shaping
In this section, pulse shaping structure is formed.
* Place an “MT Generate Filter Coefficients.vi” inside the Case Structure box (Functions Palette
> RF Communications > Modulation > Digital > Utilities > MT Generate Filter Coefficients.vi).
* Connect “modulation type” in the second Unbundle by Name to the modulation type input of
“MT Generate Filter Coefficients.vi”.
* Connect “pulse shaping filter” in the second Unbundle by Name to the pulse shaping filter
(none) input of “MT Generate Filter Coefficients.vi”.
* Connect “filter parameter” in the second Unbundle by Name to the filter parameter input of
“MT Generate Filter Coefficients.vi”.
* Connect “filter length (symbols)” in the second Unbundle by Name to the filter length
(symbols) input of “MT Generate Filter Coefficients.vi”.
c) Upsampling
In this section, upsampling structure is formed.
* Place an “Upsample.vi” inside the case structure box (Functions Palette > Signal Processing >
Signal Operation > Upsample.vi).
* Move “input” inside the Case Structure box and connect its output to the X input of
“Upsample.vi”.
* Connect the pulse shaping samples per symbols (16) input of “MT Generate Filter
Coefficients.vi” to the upsampling factor input of “Upsample.vi” and then connect “Tx
oversample factor” in the first Unbundle by Name to this wire.
* Right click on the wire from “Tx oversample factor” and create an indicator (Right click menu
> Create > Indicator).
* Change indicator name from “TX oversample factor” to “samples/symbol”.
* Place a “Convolution.vi” inside the case structure box (Functions Palette > Signal Processing >
Signal Operation > Convolution.vi).
* Connect the Upsampled Array output of “Upsample.vi” to the Y input of “Convolution.vi”.

* Move “filter coefficients” inside the case structure box and connect it to the pulse shaping
filter coefficients output of “MT Generate Filter Coefficients.vi”.
* Connect the X input of “Convolution.vi” to the above connection wire.
* Move “output” inside the case structure box and connect it to the X*Y output of
“Convolution.vi”.
d) Necessary connections
In this section, necessary error in – error out connections are made in order to finalize VI
design.
* Connect “error in (no error)” to the error in (no error) input of “MT Generate Filter
Coefficients.vi” and the error out output of “MT Generate Filter Coefficients.vi” to “error out”.
The case name “True” turns into “No Error” and “False” turns into “Error”.
* Change the case to “Error” and connect “error in (no error)” to “error out”.
At the end, your block diagram should look like the one below in Fig 1 and your front panel
should look like the one in Fig 2:

Fig 1 – Complete block diagram

Fig 2 – Complete front panel
For visual reference, check this video out (note to Gil: please add your video here): See the
video: How to build Lab4_pulse_shaping_student.vi
* In order to check if your file has errors click on Operate > Run (OR Ctrl+R). If no error window
is generated, then your file is good.
* SAVE it AS a new file by adding your name at the end (example: if your name is John, then the
new file name is “student_pulse_shaping_John.vi”).
PART-2: MATCHED FILTERING
INPUTS: Input complex waveform (cluster of 3 elements: t0 (double [64-bit real (~ 15 digits
precision)]), dt (double [64-bit real (~ 15 digits precision)]), and Y (1-D array of double complex
[~15 digit precision])).

OUTPUTS: Output complex waveform (cluster of 3 elements: t0 (double [64-bit real (~ 15 digits
precision)]), dt (double [64-bit real (~ 15 digits precision)]), and Y (1-D array of double complex
[~15 digit precision])).
A virtual instrument template (“student_matched_filtering.vit”) is provided to you with these
inputs and outputs. The template should be populated according to instructions. Then, newly
created VIs are plugged in the simulator and transmitter USRP control files.
PROCEDURE
In this part, we develop a LabVIEW virtual instrument as a matched filter that can use the pulse
train, received using USRP N210 as the receiving hardware, as input and matched filters it into
clearer (less noisy) pulses which makes it easier to digitally demodulate and decode them.
We now detail the construction of the VI at hand in Lab View:
a) Setup
* Open the LabVIEW program (Start > All Programs > National Instruments > LabVIEW 2012 >
LabVIEW 2012).
* Open “student_matched_filtering.vi” file (Open Existing (OR Ctrl+O) > Select “student_
matched_filtering.vi” > OK). A basic graphic user interface (GUI) opens. (NOTE: If a warning
window pops up, click on “Ignore” option.)
* Open Block Diagram (Window > Show Block Diagram (OR Ctrl+E)).
* Enable Functions Palette (View > Functions Palette or right click on anywhere of the block
diagram window).
* Place a Case Structure box (Functions Palette > Programming > Structures > select and drag
Case Structure) to enclose the “input complex waveform”.
* Place an Unbundle By Name inside the Case Structure box (Functions Palette > Programming >
Cluster, Class, & Variant > Unbundle By Name).
* Place two more of Unbundle By Name inside the Case Structure box (In order to copy, click on
the item and drag while holding the Ctrl key).
b) Organizing parameters
In this section, the parameters selected by user on the front panel are organized using
unbundling and bundling functions.

* Connect “modulation parameters in” to the input of one of the Unbundle By Name elements.
Stretch this element so that you can see two boxes in it (“modulation type” and “pulse shaping
parameters”).
* Left click on the “modulation type” box of this Unbundle By Name and select “All Elements”
under “pulse shaping parameters” (Left click menu > pulse shaping parameters > All Elements).
* Both boxes read “pulse shaping parameters”. Right click on the second one and select the “RX
oversample factor” option under “Select Item” menu (Right click menu > Select Item > RX
oversample factor).
* Connect the second Unbundle by Name to the first one.
* The second box reads “modulation type”. Extend it by stretching from edges so that it
displays 4 boxes.
c) Matched filtering
In this section, matched filtering structure is formed.
* Place an “MT Generate Filter Coefficients.vi” inside the Case Structure box (Functions Palette
> RF Communications > Modulation > Digital > Utilities > MT Generate Filter Coefficients.vi).
* Connect the modulation type output of the second Unbundle By Name to the modulation type
input of “MT Generate Filter Coefficients.vi”.
* Connect the pulse shaping filter output of the second Unbundle By Name to the pulse shaping
filter (none) input of “MT Generate Filter Coefficients.vi”.
* Connect the filter parameter output of the second Unbundle By Name to the filter parameter
input of “MT Generate Filter Coefficients.vi”.
* Connect the filter length (symbols) output of the second Unbundle By Name to the filter
length (symbols) input of “MT Generate Filter Coefficients.vi”.
* Connect the RX oversample factor output of the first Unbundle By Name to the matched
samples per symbol (16) input of “MT Generate Filter Coefficients.vi”.
* Place a “Convolution.vi” inside the case structure box (Functions Palette > Signal Processing >
Signal Operation > Convolution.vi).
* Connect the matched filter coefficients output of “MT Generate Filter Coefficients.vi” to the X
input of “Convolution.vi”.

* Connect “input complex waveform” to the input of the third Unbundle By Name element.
* The box reads “t0”. Change it to “Y” (Right click menu > Select Item > Y).
* Connect its output to the Y input of “Convolution.vi”.
* Connect the wire between “input complex waveform” and the third Unbundle By Name to the
input cluster input of Bundle By Name.
* Place a Bundle By Name inside the Case Structure box (Functions Palette > Programming >
Cluster, Class, & Variant > Bundle By Name).
* Move “output complex waveform” inside the Case Structure box and connect it to the output
cluster output of Bundle By Name.
* Connect the X*Y output of “Convolution.vi” to the element input of Bundle By Name.
* The box reads “t0”. Change it to “Y” (Right click menu > Select Item > Y).
d) Necessary connections
In this section, necessary error in – error out connections are made in order to finalize VI
design.
* Connect “error in (no error)” to the error in (no error) input of “MT Generate Filter
Coefficients.vi” and the error out output of “MT Generate Filter Coefficients.vi” to “error out”.
The case name “True” turns into “No Error” and “False” turns into “Error”.
* Change the case to “Error” and connect “error in (no error)” to “error out”.
At the end, your block diagram should look like the one below in Fig 3 and your front panel
should look like the one in Fig 4:

Fig 3 – Complete block diagram

Fig 4 – Complete front panel

For visual reference, check this video out (note to Gil: please add your video here): See the
video: How to build Lab_4_matched_filtering.vi
* In order to check if your file has errors click on Operate > Run (OR Ctrl+R). If no error window
is generated, then your file is good.
* SAVE it AS a new file by adding your name at the end (example: if your name is John, then the
new file name is “student_matched_filtering_John.vi”).
PART-3: SIMULATION
In this part we use the provided transmitter and receiver templates to plug in our VI files and
test their operation before using them with the USRP boards.
In order to simulate your pulse shaping and matched filtering designs, please follow these
steps:
* Open the LabVIEW program (Start > All Programs > National Instruments > LabVIEW 2012 >
LabVIEW 2012)
a) Transmitter setup
* Open “transmitter.vi” file (Open Existing (OR Ctrl+O) > Select “transmitter.vi” > OK). A basic
graphic user interface (GUI) opens. (NOTE: If a warning window pops up, click on “Ignore”
option.)
* Open Block Diagram (Window > Show Block Diagram (OR Ctrl+E)).
* Locate the “modulate.vi” (MOD) in the block diagram and replace it with the modulation file
you created in Lab 3 (Right click on the “MOD” box > Replace > All Palettes > Select a VI…>insert
your “Lab3_modulate_<name>.vi” file).
* Locate the “pulse_shaping.vi” (pulse shaping) in the block diagram and replace it with your
newly created “student_pulse_shaping_<name>.vi” file (Right click on the “pulse shaping” box >
Replace > All Palettes > Select a VI…>insert your “student_pulse_shaping_<name>.vi” file).
b) Receiver setup
* Open “receiver.vi” file (Open Existing (OR Ctrl+O) > Select “receiver.vi” > OK). A basic graphic
user interface (GUI) opens. (NOTE: If a warning window pops up, click on “Ignore” option.)
* Open Block Diagram (Window > Show Block Diagram (OR Ctrl+E)).

* Locate the “decode.vi” (decode) in the block diagram and replace it with the decoding file you
created in Lab 3 (Right click on the “decode” box > Replace > All Palettes > Select a VI…>insert
your “Lab3_decode_<name>.vi” file).
* Locate the “matched_filtering.vi” (matched filter) in the block diagram and replace it with
your newly created “student_matched_filtering_<name>.vi” file (Right click on the “matched
filter” box > Replace > All Palettes > Select a VI…>insert your
“student_matched_filtering_<name>.vi” file).
c) Simulator setup
* Open “simulator.vi” file (Open Existing (OR Ctrl+O) > Select “simulator.vi” > OK). A basic
graphic user interface (GUI) opens. (NOTE: If a warning window pops up, click on “Ignore”
option.)
* Click on “Run Continuously” button (two looping arrows).
d) Data collection
Bring up the simulator front panel and perform the following measurements shown on Fig 5, 6,
and 7. Detailed information on front panel objects can be found in Appendix-A of this
document.

Fig 5 – Simulator front panel – received constellation view

Fig 6 – Simulator front panel – eye diagram view with ideal noise power setting (-infinity)

Fig 7 – Simulator front panel – eye diagram view with more realistic noise power setting (15 dB)

Repeat the simulation using following filter parameter settings “1”, “0.75”, “0.5”, “0.25”, and
“0” for both BPSK and QPSK and collect screenshots of both constellation and eye diagram
views. They should be used for report preparation.
PART-4: USRP OPERATION

In this part we use the provided top_tx and top_rx templates to plug in our VI files and use
them with the USRP boards.
In order to operate using USRPs, please follow these steps:
* Open the LabVIEW program (Start > All Programs > National Instruments > LabVIEW 2012 >
LabVIEW 2012).
a) Transmitter setup
* Open “transmitter.vi” file (Open Existing (OR Ctrl+O) > Select “transmitter.vi” > OK). A basic
graphic user interface (GUI) opens. (NOTE: If a warning window pops up, click on “Ignore”
option.)
* Open Block Diagram (Window > Show Block Diagram (OR Ctrl+E)).
* Locate the “modulate.vi” (MOD) in the block diagram and replace it with the modulation file
you created in Lab 3 (Right click on the “MOD” box > Replace > All Palettes > Select a VI…>insert
your “student_modulate_<name>.vi” file).
* Locate the “pulse_shaping.vi” (pulse shaping) in the block diagram and replace it with your
newly created “student_pulse_shaping_<name>.vi” file (Right click on the “pulse shaping” box >
Replace > All Palettes > Select a VI…>insert your “student_pulse_shaping_<name>.vi” file).
* Open “top_tx.vi” file (Open Existing (OR Ctrl+O) > Select “top_tx.vi” > OK). A basic graphic
user interface (GUI) opens. (NOTE: If a warning window pops up, click on “Ignore” option.)
* Open Block Diagram (Window > Show Block Diagram (OR Ctrl+E)).
* Set the following values in Table 1 on top_tx front panel, HW parameters tab:
LABEL
USRP IP Address
Active antenna
Carrier frequency (in HZ)
Gain (in dB)
Generation Mode

VALUE
<IP> from NI-USRP configuration utility
J1
2.47G
10
Continuous

Table 1 – Top_tx HW parameters settings
* Set the following values in Table 2 on top_tx front panel, modulation parameters tab:
LABEL
TX oversample factor

VALUE
10

TX Sample Rate
Packet length (bits)
Pulse shaping filter
Training Sequence Type

2M
200
Raised Cosine
Length 16 Frank Sequence

Table 2 – Top_tx modulation parameters settings
* Click on “Run Continuously” button (two looping arrows).
b) Receiver setup
On another computer with a connected USRP:
* Open “receiver.vi” file (Open Existing (OR Ctrl+O) > Select “receiver.vi” > OK). A basic graphic
user interface (GUI) opens. (NOTE: If a warning window pops up, click on “Ignore” option.)
* Open Block Diagram (Window > Show Block Diagram (OR Ctrl+E)).
* Locate the “decode.vi” (decode) in the block diagram and replace it with the decoding file you
created in Lab 3 (Right click on the “decode” box > Replace > All Palettes > Select a VI…>insert
your “Lab3_decode_<name>.vi” file).
* Locate the “matched_filtering.vi” (matched filter) in the block diagram and replace it with
your newly created “student_matched_filtering_<name>.vi” file (Right click on the “matched
filter” box > Replace > All Palettes > Select a VI…>insert your
“student_matched_filtering_<name>.vi” file).
* Open “top_rx.vi” file (Open Existing (OR Ctrl+O) > Select “top_rx.vi” > OK). A basic graphic
user interface (GUI) opens. (NOTE: If a warning window pops up, click on “Ignore” option.)
* Set the following values in Table 3 on top_rx front panel, HW parameters tab:
LABEL
USRP IP Address
Active antenna
Carrier frequency (in HZ)
Gain (in dB)

VALUE
<IP> from NI-USRP configuration utility
J1
2.47G
20

Table 3 – Top_rx HW parameters settings
* Set the following values in Table 4 on top_rx front panel, modulation parameters tab:
LABEL
RX oversample factor

VALUE
10

RX Sample Rate
Pulse shaping filter
Training sequence

2M
Raised Cosine
Frank

Table 4 – Top_rx modulation parameters settings
* Click on “Correct Frequency Offset” button.
* Click on “Run Continuously” button (two looping arrows).
For visual reference, check this video out: See the video: How to build USRP operation
c) Data Collection
Your top_tx (which we use to control the transmitting USRP) window should look like the ones
in Fig 8 and Fig 9 below:

Fig 8 – Top_tx front panel when BPSK is selected as modulation type

Fig 9 – Top_tx front panel when QPSK is selected as modulation type
Your top_rx (which we use to control the receiving USRP) window should look like the ones
in Fig 10 and Fig 11 below:

Fig 10 – Top_rx front panel when BPSK is selected as modulation type

Fig 11 – Top_rx front panel when QPSK is selected as modulation type
Detailed information on front panel objects can be found in Appendix-A of this document.
Bring up the top_tx and top_rx front panels and perform the measurements shown on Fig 8, 9,
10, 11 above.
Repeat the USRP operation using following filter parameter settings “1”, “0.75”, “0.5”, “0.25”,
and “0” for both BPSK and QPSK and collect screenshots of both top_tx and top_rx front panels.
They should be used for report preparation.
On top_tx.vi: Click on the “User Defined Mode” button (it will turn to green). Click on the “Send
Text?” button (it will turn to green). Write down a text to transmit (for example: “SEND TEST
MESSAGE”) in “Type text here” box. Start transmission. Observe the received message on
top_rx.vi window. Collect screenshots of both top_tx and top_rx front panels. They should be
used for report preparation.
PART-5: HOMEWORK QUESTIONS

#1: Write a lab report describing the experiments and results you observed. Include in the
report the images you collected in Part-3 and Part-4.
#2: Answer the following questions:
• What is the effect of filter parameter in simulation on both constellation and eye
diagram?
• What is the difference between simulation and USRP operation?

APPENDIX A
PART-1: SIMULATION
On “simulator.vi” front panel you can manipulate the following values:
TRANSMITTER SECTION
a) TX oversample factor: Data type is long [32-bit integer (-2147483648 to 2147483647)]. This
specifies the number of desired samples per symbol for the pulse shaping filter. It must be
an even number larger than 2.
b) TX sample rate: Data type is double [64-bit real (~15 digit precision)]. This specifies the
transmitter sampling rate in Hertz (or samples per second). It must be specified between
195.312k and 100M.
c) Noise power: Data type is double [64-bit real (~15 digit precision)]. This specifies the level
of noise power in dB. It can be any value between –Infinity (Inf) and +Inf.
RECEIVER SECTION
d) RX oversample factor: Data type is long [32-bit integer (-2147483648 to 2147483647)]. This
specifies the number of desired samples per symbol for the pulse shaping filter. It must be
an even number larger than 2. It should be same as TX oversample factor.
e) RX sample rate: Data type is double [64-bit real (~15 digit precision)]. This specifies the
transmitter sampling rate in Hertz (or samples per second). It must be specified between
195.312k and 100M.
f) Correct frequency offset: Data type is Boolean [TRUE or FALSE]. This compensates the
effect of the frequency offset between transmitted and received signals. It can be set as on
or off.
SHARED SECTION

g) Modulation type: Data type is string. This chooses the modulation scheme to be used in
both transmitter and receiver. It can be either BPSK or QPSK.
h) Packet length: Data type is long [32-bit integer (-2147483648 to 2147483647)]. This
specifies the packet length to be transmitted and received in bits.
i) Iterations: Data type is long [32-bit integer (-2147483648 to 2147483647)]. This changes
how many times the simulation is performed. Higher number of iterations increases the
accuracy, but decreases the processing speed.
j) Training sequence type: Data type is string. This chooses the training sequence to be used
in both transmitter and receiver. It can be Length 11 Barker Sequence, Length 16 Frank
Sequence, or Neumann Hoffman Binary Code.
k) Pulse shaping filter: Data type is unsigned word [16-bit integer (0 to 65535)]. This selects
the pulse shaping and matched filtering pulses to be used in both transmitter and receiver.
It can be Raised Cosine, Root Raised Cosine, or Gaussian.
l) Filter parameter: Data type is double [64-bit real (~15 digit precision)]. It sets the roll-off (or
excess bandwidth) factor for Raised Cosine and Root Raised Cosine filters. It can be any real
number between 0 and 1.
In the graph field you see four different tabs:
1)
Received constellation: This graph shows continuously changing I (in-phase or real)
and Q (quadrature or imaginary) values of the constellation points as symbols
received. These constellation points are the ones detected by the ML detector we
constructed in Part-2.
2)
Received eye diagram: An “eye diagram” is an oscilloscope display in which a digital
data signal from a receiver is repetitively sampled and applied to the vertical input,
while the data rate is used to trigger the horizontal sweep. It is called so because its
shape resembles an eye. An open eye pattern corresponds to minimal signal
distortion (due to intersymbol interference and noise).
3)
Received signal: These two graphs show the Amplitude (in Volts) change of the
received signal I and Q components in time domain.
4)
Power delay profile: This graph gives the amplitude of the signal received through a
multipath channel as a function of time delay (sec). The time delay is the difference
in travel time between multipath arrivals.
PART-2: USRP OPERATION
On “Top_tx.vi” and “Top_rx.vi” front panels you can manipulate the following common values:
HW PARAMETERS TAB

a) Device name: Data type is IVI session of class niUSRP. This area is to enter the IP address of
the connected USRP.
b) Active antenna: Data type is string. This area is to enter the antenna name to be used.
c) Carrier frequency: Data type is double [64-bit real (~15 digit precision)]. This area is to enter
the frequency of RF signal in Hertz (Hz).
d) Gain: Data type is double [64-bit real (~15 digit precision)]. This area is to enter the
aggregate gain applied to the RF signal in decibel (dB).
MODULATION PARAMETERS TAB
e) Modulation type: Data type is string. This chooses the modulation scheme to be used in
both transmitter and receiver. It can be either BPSK or QPSK.
f) TX (or RX) oversample factor: Data type is long [32-bit integer (-2147483648 to
2147483647)]. This specifies the number of desired samples per symbol for the pulse
shaping filter. It must be an even number larger than 2.
g) TX (or RX) sample rate: Data type is double [64-bit real (~15 digit precision)]. This specifies
the transmitter sampling rate in Hertz (or samples per second). It must be specified
between 195.312k and 100M.
h) Pulse shaping filter: Data type is unsigned word [16-bit integer (0 to 65535)]. This selects
the pulse shaping and matched filtering pulses to be used in both transmitter and receiver.
It can be Raised Cosine, Root Raised Cosine, or Gaussian.
i) Filter parameter: Data type is double [64-bit real (~15 digit precision)]. It sets the roll-off (or
excess bandwidth) factor for Raised Cosine and Root Raised Cosine filters. It can be any real
number between 0 and 1.
j) Training sequence type: Data type is string. This chooses the training sequence to be used
in both transmitter and receiver. It can be Length 11 Barker Sequence, Length 16 Frank
Sequence, or Neumann Hoffman Binary Code.
The following items are only on top_rx.vi:
k) Correct frequency offset: Data type is Boolean [TRUE or FALSE]. This compensates the
effect of the frequency offset between transmitted and received signals. It can be set as on
or off.
l) Training sequence: Data type is unsigned word [16-bit integer (0 to 65535)]. This chooses
the training sequence to be used in the receiver. It can be Barker, Frank, or Neumann H.
In the graph fields of “top_tx.vi” and “top_rx.vi” you see the following graphs:
1)
(top_tx) Transmitted constellation: This graph shows the theoretical/ideal
constellation points for the selected modulation scheme (two constellation points
one at (I,Q)=(+1,0) and the other one at (-1,0) for BPSK; four constellation points one

2)

3)

4)

at (I,Q)=(+0.707,+0.707), second at (+0.707,-0.707), third at (-0.707,+0.707), and
fourth at (-0.707,-0.707) for QPSK).
(top_rx) Signal constellation: This graph shows continuously changing I (in-phase or
real) and Q (quadrature or imaginary) values of the constellation points as symbols
received.
(top_tx and top_rx) Eye diagram: It is shown on both transmitting and receiving
window. The transmitting window diagram is static, while receiving window diagram
is dynamic.
Received signal: These two graphs show the Amplitude (in Volts) change of the
received signal I and Q components in time domain.

m) Type text here: Data type is string. When you click on the “User Defined Mode” and then
the “Send Text?” buttons, you can enter your text inside this box and read in from the
top_rx.vi window. This part is shown in Fig. 12 below:

Fig. 12 – Sending text part of top_tx.vi

In order to export the values of a graph or array on the simulation window, follow this path and
pick the output format you need: Right click on the graph/array > Export > Export
(clipboard/excel/simplified image).
In order to copy the current value of an indicator, right click on the indicator while simulation is
running and select “Copy Data”. This copies the current value as an image.
Also, if you need to run the simulator only for one loop, you can click on the single arrow
(“Run”).

